Hem » Compilesdkversion is not specified. please add it to build.gradle

Compilesdkversion is not specified. please add it to build.gradle

by Jens Engblom

CompileSDKVersion ist nicht angegeben: Lösung für build.gradle

Beim Erstellen einer Android-App kann es vorkommen, dass die Fehlermeldung ”CompileSDKVersion is not specified” auftritt. In diesem Artikel erfahren Sie, wie Sie diesen Fehler beheben können, indem Sie die CompileSDKVersion in Ihrer build.gradle-Datei angeben.

Fehlerbehebung: CompileSDKVersion hinzufügen

Um den Fehler ”CompileSDKVersion is not specified” zu beheben, müssen Sie die fehlende CompileSDKVersion in Ihrer build.gradle-Datei hinzufügen. Öffnen Sie dazu Ihre build.gradle-Datei und fügen Sie die folgende Zeile hinzu:

compileSdkVersion [VERSIONSNUMMER]

Ersetzen Sie dabei [VERSIONSNUMMER] durch die tatsächliche Versionsnummer der von Ihnen verwendeten Android SDK-Version. Sie sollten darauf achten, dass die Versionsnummer mit der TargetSDKVersion übereinstimmt, die Sie weiter unten in der build.gradle-Datei angegeben haben.

Versionsnummer Android-Version API-Level
29 Android 10.0 API 29
28 Android 9.0 API 28
27 Android 8.1 API 27
26 Android 8.0 API 26

Tipp: Prüfen Sie auch die Abhängigkeiten

Nachdem Sie die CompileSDKVersion in Ihrer build.gradle-Datei ergänzt haben, überprüfen Sie auch die Abhängigkeiten. Stellen Sie sicher, dass alle verwendeten Bibliotheken und Plugins mit der angegebenen Android-Version kompatibel sind. Falls erforderlich, aktualisieren Sie die betreffenden Bibliotheken oder Plugins.

Zusammenfassung

Der Fehler ”CompileSDKVersion is not specified” kann behoben werden, indem Sie die fehlende CompileSDKVersion in die build.gradle-Datei eingeben. Es ist wichtig, dass Sie die richtige Versionsnummer verwenden und die Kompatibilität von Bibliotheken und Plugins sicherstellen. Wenn Sie die oben beschriebenen Schritte befolgen, können Sie Ihr Android-Projekt nun erfolgreich erstellen.

Related Posts